SoulSteel - Progression loss issues while transferring servers – Incident details

All systems operational

Progression loss issues while transferring servers

Monitoring
Major outage
Started about 1 month ago

Affected

SoulSteel

Major outage from 9:33 AM to 9:12 AM, Operational from 9:12 AM to 12:00 AM

Updates
  • Update
    Update

    We've been working today on getting access restored to as many people as possible. The majority of affected players have been restored, and we're working with Mojang to restore the remaining profiles as soon as we can - thanks for bearing with us!

    We plan to give out compensation for the downtime next week. Monday is a bank holiday in the UK, so we will start looking into this on Tuesday.

  • Update
    Update

    We're now working to recover the data of everyone that was affected. We hope to restore everyone by the end of the working day today (BST) - that said, recovery is a complicated manual process that takes a lot of time, so it may take longer.

    If you are unable to join SoulSteel, or believe you have been affected by the issue, please contact our support team at https://support.soulsteel.net if you haven't already.

    Thank you once again for your continued patience while we get everything sorted!

  • Monitoring
    Monitoring

    Good news, the server is back online!

    The dev team have investigated the issue and the server is now free of that pesky bug. We have temporarily banned those affected while we go through the recovery process. Once progress is restored, they will regain access to the server.

    Once that's all done, we'll look into compensation for the downtime and for those with active boosts during that downtime.

    Thank you all so much for your patience while we sorted this out

  • Identified
    Identified

    We believe that we have found the root cause of the issue, and are continuing to work with Mojang to rectify it. We hope to have another update to share soon.

  • Investigating
    Investigating

    We are aware of issues with some players losing their progress when joining or moving between game servers. We are therefore temporarily taking SoulSteel offline while we investigate to prevent any further issues.